These forums are read-only. Please send questions and feedback by email.

Directory Date Format Problem

Use this forum to ask any questions and to submit bug reports

Moderator: vuser

GeorgeB
Posts: 15
Joined: Fri Feb 11, 2011 8:52 pm

Directory Date Format Problem

Postby GeorgeB » Fri Mar 04, 2016 8:48 am

I don't know what, if anything, I did, but the date format in the directory and file listings now have commas instead of slashes:

As displayed in V (using File-> Copy to clipboard):

v.exe 02,13,2016

As displayed in Windows Explorer (apparently using the long date format):

v.exe Sat, 02/13/2016 12:30PM

The date in the Systray clock/cal displays with the slashes. I tried searching the V help, then the internet, but can't find anything useful in this situation.

I know I'm going to feel pretty silly at the simple answer, but this won't be the first time (nor the last! <g>).

V 15 SR 1, FWIW.

Thanks,

--George

FileViewer
Site Admin
Posts: 286
Joined: Fri Apr 30, 2010 5:50 pm

Re: Directory Date Format Problem

Postby FileViewer » Fri Mar 04, 2016 3:02 pm

I don't know what, if anything, I did, but the date format in the directory and file listings now have commas instead of slashes:

That's very strange. V gets the date separator from Windows but I have never seen a comma as a date separator!

Have a look at the Windows Regional Date/Time settings. The easiest way to do this is to type "Region" into the start button and then select "Region and Language".

The Formats tab and the Additional Settings section should display what the date separator used for formatting.

Also, if you haven't restarted your PC since the problem appeared, please do so to see if the problem goes away.

GeorgeB
Posts: 15
Joined: Fri Feb 11, 2011 8:52 pm

Re: Directory Date Format Problem

Postby GeorgeB » Sat Mar 05, 2016 9:08 am

Okay, after lots of circles-going-around-in, I found where the problem is coming from.

I just recently changed my Short date format to: "ddd, MM/dd/yyyy"
so that the Systray clock-cal would display as "Sat, 03/06/2016" instead of "03/06/2016". Adding the comma after the "ddd" apparently results in V replacing the forward slashes with commas. It doesn't adversely affect any other program (so far).

When I changed it to "ddd - MM/dd/yyyy", V put the slashes back in. When I change to "MM/dd/yyyy, ddd" V displays the date with the slashes.

This is where I'm leaving my short date for now. I checked a few other programs, many seem to ignore the short date setting and use there own formats (dashes instead of slashes for instance), but one prog I use a lot (Beyond Compare, a file/folder comparison tool) uses the slash and is apparently unaffected by these changes. Windows Explorer is affected by the short date setting, shows the slashes no matter what, but who cares?

This didn't show up right away because I hadn't re-booted lately. I sometimes open a 2nd instance of V, and when I did, that's when the commas showed up. Going back to the 1st instance, apparently V refreshed and there were the commas. I installed the SR 1 update, but obviously that didn't help.

I bet you thought I'd lost my touch and couldn't find a way to break V after all this years. Yeah, I still got it. :D

--George "The Hammer"


Return to “General Support”

Who is online

Users browsing this forum: No registered users and 2 guests