These forums are read-only. Please send questions and feedback by email.

[v14.0.0.1 (SR1)] Problem with copy and paste

Use this forum to ask any questions and to submit bug reports

Moderator: vuser

SwissBIT

[v14.0.0.1 (SR1)] Problem with copy and paste

Postby SwissBIT » Sat Sep 14, 2013 2:22 pm

Dear Support,

I have a problem with copy and Paste:

My V File Viewer version is v14.0.0.1 (SR1) 64-bit.

I have tried the following text (from a text block) to copy, and then paste in my text-editor:

<Exec>
<Command>hstart64.exe</Command>
<Arguments>/NOCONSOLE /WAIT "tcc.exe /C "c:\Users\All Users\Scripts\WFP_Blocking-MSG_1.btm" "$(Application)" $(SourceAddress) $(DestAddress) $(Protocol) $(SourcePort) $(DestPort) $(ProcessID)"</Arguments>
</Exec>

From /NOCONSOLE ... until $(ProcessID)" - which means the following ...

/NOCONSOLE /WAIT "tcc.exe /C "c:\Users\All Users\Scripts\WFP_Blocking-MSG_1.btm" "$(Application)" $(SourceAddress) $(DestAddress) $(Protocol) $(SourcePort) $(DestPort) $(ProcessID)"

... this selected text above is without linebreak (it's ONE line), it's wrapped only at V window border.

But then, after inserting the text looks like this:

/NOCONSOLE /WAIT "tcc.exe /C "c:\Users\All Users\Scripts\WFP_Blocking-MSG_1.btm" "$(Application)"

(the last "sign" is a space). Of course, this is not correct! It copies until wrapping but not more ... Please see also these attachments ...

Capture1.JPG
Capture1
Capture1.JPG (41.7 KiB) Viewed 4598 times

Capture2.JPG
Capture2
Capture2.JPG (41.02 KiB) Viewed 4598 times

I found no solution to copy and paste this text correctly - also not with different preferences or LOF-options - except without wrapping, then it's no problem!

Is this a bug?

Kind regards,
SwissBIT

PS: Registered User

PPS: Sorry for my bad english ...

FileViewer
Site Admin
Posts: 286
Joined: Fri Apr 30, 2010 5:50 pm

Re: [v14.0.0.1 (SR1)] Problem with copy and paste

Postby FileViewer » Sat Sep 14, 2013 6:41 pm

I found no solution to copy and paste this text correctly - also not with different preferences or LOF-options - except without wrapping

You need to enable "Do not copy CR/LF to clipboard for wrapped lines" in the File Options section of Preferences.

If you do not enable this option, the line will be copied as 2 lines instead of one line.

If you still have problems after enabling this option, please send the file you are copying from to v at fileviewer.com

SwissBIT

Re: [v14.0.0.1 (SR1)] Problem with copy and paste

Postby SwissBIT » Wed Sep 18, 2013 6:20 am

Thank you for answer and sorry for my late reaction to this!

Yes, I still have problems and I had tested with enable this option ...

In the attachment is a little test file (test.txt packed in test.zip). Please make exactly the steps which I described above, thank you!

Kind regards,
SwissBIT

PS: Also if "Do not copy CR/LF to clipboard for wrapped lines" is disabled, the copy and paste function is not correct with my example!
Attachments
Test.zip
Test.txt packed in Test.zip
(332 Bytes) Downloaded 367 times

FileViewer
Site Admin
Posts: 286
Joined: Fri Apr 30, 2010 5:50 pm

Re: [v14.0.0.1 (SR1)] Problem with copy and paste

Postby FileViewer » Wed Sep 18, 2013 8:40 pm

In the attachment is a little test file (test.txt packed in test.zip)

Thank you for the file.

I have confirmed that this is a bug with the current version. It will be fixed in the next V14 service release which should be available next week.

SwissBIT

Re: [v14.0.0.1 (SR1)] Problem with copy and paste

Postby SwissBIT » Thu Sep 19, 2013 6:20 am

FileViewer wrote:
In the attachment is a little test file (test.txt packed in test.zip)

Thank you for the file.

I have confirmed that this is a bug with the current version. It will be fixed in the next V14 service release which should be available next week.


Thank you for your support!


Return to “General Support”

Who is online

Users browsing this forum: No registered users and 1 guest